Showing results for 
Search instead for 
Did you mean: 

ST Link Unable to connect to 3 Dev Boards


I am having trouble connecting ST development boards to my computer.  I have tested the following development boards:


I had trouble connecting when I had Windows 10, I just upgraded to Windows 11 and have the same problem.  All the trouble shooting I have done has been on Windows 11.  

When I plug in to my computer via USB the development board's red light continuously blinks, showing that the board has power.

When I go into device manager, I can not find the COM port for the nucleo, showing that the board is not communicating with the computer.

Steps I have already taken to troubleshoot:
-Tried multiple boards
-Tried 2 different USB cables
-Tried 2 different USB ports (both seem to work with my mouse leading me to beleave it is not the USB port)
-Installed STM32 ST-LINK Utility
      +It could not connect
-Reinstalled the ST-LINK driver  (en.stsw-link009)
      +I ran the install as an administrator and at the end of the install wizard it showed 3 drivers with green check marks next to them, leading me to beleave they were installed

Any further ideas would be greatly appreciated.  I