Showing results for 
Search instead for 
Did you mean: 

problem with stm32g474cet6 - no connection via swd


Hello everyone. I have a homemade board with a stm32g474cet6 processor. I can't connect to the processor via swd, while if boot0 is closed to +3.3v, then the chip is perfectly programmed via uart. I rechecked the board, all the blocking capacitors are installed, the contact from the programmer along the lines of swdio, swclk is, boot0 is connected to the ground. I even tried to solder the chip - the behavior does not change. I tried to connect Hard Reset, Connect under Reset - it does not connect. What am I doing wrong?


I had similar problem with STM32F407VGT6, ST-link stopped recognizing STM32. It only recognized again with the ST-LINK utility (running on Windows), I did a full FLASH erase. This has happened more than once.

After following this tip, it didn't happen anymore:

Note: If the pins PA13 (SWDIO) and PA14 (SWCLK) are used (configured for another option other than the default state) it may prevent the ST-Link from working, to solve this problem, keep the BOOT0 (pin 94) in logical state high (3.3V) before energizing (reset the microcontroller). To not need to manually change the BOOT0 pin, keep the pins PA13 (SWDIO) and PA14 (SWCLK) unused, it also cannot be configured as input.


If you connect BOOT0 to 3.3V during reset, and SWD still doesn't work, likely there's a hardware issue between the chip and the programmer. Look for solder bridges, cold solder joints or other hardware issues. Double check wiring is correct. Make sure you are connecting GND in addition to SWDIO/SWCLK. You can program via UART, so you know the chip is running and power is okay.

If you feel a post has answered your question, please click "Accept as Solution".