Showing results for 
Search instead for 
Did you mean: 

Nucleo-64 ST-Link to program and debug an external STM32 application

Associate III


I'm trying to use ST-LINK/V2-1 from Nucleo to program and debug my board. I removed the jumpers from CN2 and connected CN4 to my board according to the manual:

Problem occurs when I tie NRST of the CN4 to the STM32 on my board - in this case  "DEV_TARGET_HELD_UNDER_RESET" message occurs. Indeed measured NRST is low.
Why it's held low?

Few details:

  • my board has pull-up on reset pin
  • without reset pin I'm able to connect to my board's STM32
  • I need all 6 pins of the CN4
  • tried to do this with two different Nucleo-64 boards (G070 & L010) with same outcome

Also manual mentions that " SB12 NRST (target STM32 RESET) must be OFF if CN4 pin 5 is used in the external
application." - tried both with/without SB12 - no luck.


Is your target board powered? Note that the 6-pin connection does not provide power.

T_NRST is only connected to the ST-Link chip, the CN4 header, and NRST via SB12. Removing SB12, there is no reason it should stay low unless something is pulling it low externally. Perhaps your board isn't powered or has another hardware issue.

I'm unable to replicate this on my own Nucleo-64 board.

If you feel a post has answered your question, please click "Accept as Solution".