Showing results for 
Search instead for 
Did you mean: 

Libusb can't access ST Link after update to Cube 1.15


Hello everyone.

I'm experiencing an issue with STM32CubeIDE. Everything worked fine until this morning when I installed the update to version 1.15. Now I cannot connect to any of my ST Links (3) which previously worked on my PC.

I'm running Cube on my M3 MacBook, I'm getting the following issue when I try to program my STM32H753:


Device connect error

Error in initializing ST-LINK device.
Reason: libusb: error [darwin_claim_interface] could not set configuration
Failed to connect to device. Please check power and cabling to target.


I'm assuming it's a problem with the operating system which is not allowing the GDB server to access the ST-Link via libusb. Can't find any help on forums, I've been searching for similar issues for hours.

I've tried all of my ST Links on a Windows HP laptop and I'm able to flash and debug correctly, so the hardware should be working fine. Before anyone asks, they are original ST Links, as I got them from original Nucleo boards.

Thank you for any help!

Pavel A.
Evangelist III

I've tried all of my ST Links on a Windows HP laptop and I'm able to flash and debug correctly

Is this after the update?

What shows system_profiler SPUSBDataType  or ioreg -p IOUSB -l -w 0?



Hi Pavel, thank you for your reply. I can't explain why, all of a sudden, this morning it restarted working, I'm sorry I made you waste your time.

I'll reply to your question anyway, this was the output with "system_profiler SPUSBDataType":

        STM32 STLink:

                  Product ID: 0x374b

                  Vendor ID: 0x0483  (STMicroelectronics)

                  Version: 1.00

                  Serial Number: 066DFF515782664867190724

                  Speed: Up to 12 Mb/s

                  Manufacturer: STMicroelectronics

                  Location ID: 0x02112000 / 8

                  Current Available (mA): 500

                  Current Required (mA): 300

                  Extra Operating Current (mA): 0

Today I can also see this in the end:



                      Capacity: 6,3 MB (6.332.416 bytes)

                      Removable Media: Yes

                      BSD Name: disk4

                      Logical Unit: 0

                      Partition Map Type: Unknown

                      S.M.A.R.T. status: Verified

                      USB Interface: 1

Could it be something with the powering of the attached device? From the error message [darwin_claim_interface] I assumed the problem was with the operating system not letting libusb access the device.

I'm trying to find an explanation in case anybody else finds themselves in this situation.

Thank you for your help!