Showing results for 
Search instead for 
Did you mean: 

Issue with STM32F401RE and X-Nucleo-53L0A1(not working)

Armin Böss
Associate II
Posted on April 09, 2017 at 23:33

I tried to program the STM32 MCU with the example code (RangingWithSatellites) from here :


, bottom of the page).

At first, i just tried to drag and drop the .bin file (from this directory: \X-CUBE-53L0A1\STM32CubeExpansion_VL53L0X_V1.2.0\Projects\Multi\Examples\VL53L0X\RangingWithSatellites\Binary) on to the F401RE Board, which worked sometimes, but not every time. I can´t figure out why it behaves like this, i tried to unplug the sensor shield, program the board and reattach the sensor shield and stuff like this but after hours, it just feels like someone is rolling some dices about whether it will work or not (what i mean with not working: the LED on the F401RE stays red and the display on the sensor shield stays dark/doesn´t react to the reset button).

Second, i programmed the MCU with the STM32 ST-LINK Utility. After programming, the Console says everything is fine and the Code is in the FLASH but this never worked for me.

Finally, i tried it with the System Workbench for STM32, but the results didn´t change.

Can this be a hardware error or am i doing something horribly wrong?

Best Regards and an apologize for my english,


ST Employee
Posted on April 11, 2017 at 18:29




Did you added your own code and made update

on the example?

May be you should check your configuration and project steps following the user manual and Quick Start Guide.


ST-LINK Utility, t

ry to upgrade firmware version using STM32 ST-LINK Utility: go to ST-LINK > firmware update,or through this Link STSW-LINK Then disconnect and connect your board.


When your question is answered, please close this topic by clicking "Accept as Solution".
Armin Böss
Associate II
Posted on April 14, 2017 at 01:21

Hi and thank you for your answer,

I didnt change the code, i just used the example from X-CUBE-53L0A1\STM32CubeExpansion_VL53L0X_V1.2.0\Projects\Multi\Examples\VL53L0X\RangingWithSatellites.

I started from the beginning again, i installed the usb driver and updated the firmware. After that, i tried it with Drag and Drop, with the ST Link Utility and the STM 32 Workbench, but it didnt change anything, the LCD keeps staying dark besides that the ST Link Utility tells me that the Code is on the FLASH Memory and the LED LD1 is green after programming with STM 32 Workbench (Indicator for a succesful communication).

Hoping someone can help me,