Showing results for 
Search instead for 
Did you mean: 

I can't blink my leds in H755ZI Nucleo board

Associate II

I bought a NUCLEO H755ZI board, but I can't make the LED connected to GPIOB pin 14 blink, neither with CMSIS nor with HAL, I saw some tutorials and questions here, but nothing solved it, thank you in advance for your help.


Accepted Solutions

Debug your code ... is while toggle run???

View solution in original post


Single Step the code, or observe with a scope

At several million cycles a second, this is not going to create a perceivable delay, and advances i twice in the loop

void Delay_ms(int ms)
	uint32_t i;

	for(i = 0; i < ms; i++)
}// end Delay_ms



Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
ST Employee

Hi @icaro_mendes00 

Did you check if R75 for LD3 is fitted? Do you have the same issue with other leds?

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

There is a resistor R26 next to LD3, would that be it? Or is it necessary to configure it in some specific way? And the same happens with other LEDs (LD1 and LD2)

Debug your code ... is while toggle run???

I use the STLINK Utility, and works, but why?