Showing results for 
Search instead for 
Did you mean: 

Regenerating a UCPD project in CubeIDE 1.6 deletes the library file from the linker settings in the project configuration.

Associate III

This thread is a new problem discovered while investigating a different USB-PD issue in another thread. @Yohann M.​ recommended that I create a new thread for this issue. Here is the link to the other thread:

I've set up a basic project to run the USB-PD middleware in CubeIDE 1.6 on the Nucleo-G071RB dev board. Basically, turn on UCPD 1 and 2, enable freeRTOS, serial port, USBPD middleware, tracer EMB, and GUI interface. After generating the project, the library :USBPDCORE_PD3_FULL_CM0PLUS_wc32.a is missing from the linker settings in the project configuration. If I regenerate the project again, after adding the missing file, the setting is erased so that I have to add the missing file every time.

If I make a copy of the IOC file in a new directory, open it in standalone CubeMX 6.2.0, and generate the project, the library file is present in the linker settings.

I tried starting a new clean project with more or less the same settings in CubeIDE and got the same error.

The weird thing is, this error only started sometime last week. Before that, I was able to generate the project without incident.

I have attached the IOC file.



Cartu38 OpenDev
Lead II

Works like a charm on my side if IDE 1.6.0.

I'm relying on "File > New STM32 project from an existing STM32CubeMX configuration file" to create a project from your shared file. Here is result: .a library is well set.

If adding some IP setup and asking for project udate such setup is preserved.


@Cartu38 OpenDev​ 

Thanks for testing it out.

Yeah, I'm pretty sure my machine just has gremlins or something. As it stands, it's easy to fix, but annoying to have to add the file back in every time I regenerate.

Do you know where the equivalent of the \users\[username]\.stm32cubemx\STM32CubeMX.log file is for CubeIDE? That file seems to only be updated for the standalone version of CubeMX.

Cartu38 OpenDev
Lead II

if STM32CubeIDE log file are located within <your workspace>/.metadata/.log & <your workspace>/.metadata/.ide.log.

Thanks! I had been searching around for a log file with the same name as the standalone one and was having no luck.

Here are both files after a regeneration starting at 2021-04-01 11:56:48,251. I don't see any obvious errors but I also don't know what I'm looking for. I added CubeIDE to the beginning of the file names and put them in a zip file because the forum upload software didn't like the .ide.log and .log filenames.

Thanks for sharing but you're right no weird trace as part of logs here.