Showing results for 
Search instead for 
Did you mean: 

We have install ST Link driver (STSW-Link009) on several Windows 10 machines, seems to install correctly but cannot connect to ST-Link V3...nothing appears in the Device Manager under the USB drivers

ST Employee

In the device manager there should be something visible. Depending on the settings there should be e.g.:

  • View > Devices by container --> STLINK-V3
  • View > Devices by type --> Universal Serial Bus devices
    • ST-Link Bridge
    • ST-Link Debug

Can you see anything of that?



In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.
Associate II

Hello Peter,

I have issues communicating with Nucleo-G431RB using usb driver STSW-LINK009 in win10.  Here is what I found.  After plugging in the use cable to my laptop, I saw an "unknow USB device (Device description request failed)" showed up in the device manager and with an exclamation mark !.  Nothing worked after that.  The driver seemed to be installed correctly, because an "USB Mass Storage Device" showed up when I plugged in Nucleo-F103RB board and communication was working normally.   Is it because the different between ST-Link/V2-1 vs. STLINK-V3 G431RB had?  How do I remedy this issue?  Thanks!