cancel
Showing results for 
Search instead for 
Did you mean: 

STM32L475 Discovery IoT Azure Hub not supported by CubeIDE

Rob Ashworth
Associate III

I have a STM32L475 IoT Development board which I'd like to get working with Cube IDE & Azure IoT Hub.  Anyone got a migrated example?.

 I can see the old project on Github which is meant for the old SW4 IDE, but when I try to import it to CubeIDE, or even SW4, it doesn't get the project built correctly (no include paths, doesn't know what source files to use etc), and having tried a couple of times to do it from scratch, I can't quite get it to compile/link.

7 REPLIES 7
KDJEM.1
ST Employee

Hello @Rob Ashworth ,

Thank you for reporting this issue.

To check the issue, could you please precise which STM32CubeIDE version are you using and the project for which you obtained the build error.

Thank you.

Kaouthar

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

I am using the latest version of CubeIDE.

I do not get a build error - I don't get that far.  It more that the hardware which can still be purchased appears not to be supported by ST anymore!

Here is the link to the Github repository - originally this was part of ST's offering, but I cannot build the project using CubeIDE.  Maybe you will have more success, in which case please update the Github repository, or create a new one please.

https://github.com/andrewperis/FP-CLD-AZURE1

Hardware is the Discovery Board, B-L475E-IOT01A or 02A.

Link from ST's website here, but as you will see no actual functioning firmware to support it.

https://www.st.com/content/st_com/en/search.html#q=B-L475E-IOT01A-t=tools-page=1

Pavel A.
Evangelist III

#bugreport

Indeed, files .project and .cproject are missing for all SW4STM projects.

 

KDJEM.1
ST Employee

Hello @Rob Ashworth ,

FP-CLD-AZURE1 package is obsolete.

 

KDJEM1_2-1704798612678.png

For that please try to use X-CUBE-AZURE: Recommended replacement product.

Thank you.

Kaouthar

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Yes, this is my complaint.  I have purchased hardware, but the ST firmware is not only obsolete, but doesn't compile even if I download it because the toolchain is not complete with the .project files.

Can I return the product the ST for a refund please if no support is to be provided?  please let me know.

Hi @Rob Ashworth 

 

The forum moderator had marked your post as needing a little more investigation and direct support. An online support case has been created on your behalf, please stand by for just a moment and you will hear from us.

 

Regards,

Billy

I now appear to have gone from one problem to another.  The reply back was that Azure IoT is not supported, something I am very annoyed about as it was so why remove it?

 

Anyway to get around the problem I have now junked that bit of hardware at my cost and purchased a STM32H573I-DK Discovery kit only to find that I have jumped from a non firmware support issue to the fact that St-LinkV3 appears not to be supported for MAC's.  Any official response ST wish to make as I have now purchased 2 piece of ST hardware I can't use.