Showing results for 
Search instead for 
Did you mean: 

I cannot code my stm32 card and the processor gets very hot.

Associate II

After connecting the USB cable, my stm32 f446re nucleo board gets very hot. Also, I cannot load code into it because ide programs do not see the card. When I apply voltage from the VIN pin, there is no heating. where is the problem, could it be in the stlink?


Likely a regulator or internal short within the part.

You can find the schematics under the CAD Resources tab of the product page

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
ST Employee

@erya35 You haven't said anything about your computer yet. I have already seen here in the Community that someone has connected a NUCLEO to a MAC, which then supplied too much voltage via USB, thereby destroying the NUCLEO or at least the ST-LINK.


In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

I am using a windows computer for coding.I was coding and using the stm32f446re card.but 2 days ago I encountered this problem. I am using Keil and I get no target error.I tried with Stm32cubeprogrammer but I could not connect to the card from there.

Thank you, I'll look into it.