Showing results for 
Search instead for 
Did you mean: 

How I solved my B-L475E-IOT01A board driver issue


The board version is MB1297E, my PC OS is windows 7, I successfully installed the driver(stsw-link009), but in device manager, it appears as "STM32 STLink" with a yellow exclamation mark, on the board, LD5 doess not light, LD6 keep flashing red.

I checked User Manual (UM2153), it says:

" During the USB enumeration, STM32L4 Discovery kit for IoT node asks for the 500 mA power to the host PC. If the host is able to provide the required power, the enumeration finishes by a “SetConfiguration�? command and then, the power transistor ST890 is switched ON, the red LED LD7 is turned ON, thus the STM32L4 Discovery kit for IoT node consumes up to 500 mA current, but no more. If the host is not able to provide the requested current,

the enumeration fails. Therefore the ST890 remains OFF and the MCU part including

the extension board is not powered"

So I thought it's probably a hardware issue at the begining, my PC might not be able to provide enough current to the USB port..

After many tryings, ( Add USB 3.0 extention card, change a better power supply, change mainboard..), I realized it's actually a software issue, for unknown reason, the driver just can't work on my PC system.

At last, I solved it by re-install the windows 7 system. the whole process took me more than 2 weeks!

Share my experience here, so that people who have same issue don't have to waste so much time on checking PC hardware.