Showing results for 
Search instead for 
Did you mean: 

STEVAL-MKI109V3 dfu issue

Associate III

Hi, I recently bought a STEVAL-MKI109V3 with STEVAL-MKI208V1K. My pc runs on Ubuntu 18.04.5 LTS.

I've installed the Unico GUI, but when selecting the STEVAL-MKI208V1K in the Unico, it says "Port not open. Please, check the board is connected."

I've tried the firmware DFU update, but when running the Step 5 of the STEVAL-MKI109V3 manual, I get "dfu-util: No DFU capable USB device available". I've tried different USB ports and cables. I believe the device is in DFU mode, because the green D1 LED doesn't blinks (if I connect normally it blinks).

Please your comments and help, thanks.



Accepted Solutions

HI @Eleon BORLINI​, my mistake, I had an error in the c++ code, now I can communicate to the STEVAL-MKI208V1K.

To close this subject, in my case it was easier and simpler to make direct communication with STEVAL-MKI208V1K using Arduino than through STEVAL-MKI109V3 and Unico GUI (using a Ubuntu 18.04.5 LTS notebook).


View solution in original post

ST Employee

Hi @FCook.1​ ,

Are you using STM32CubeProgrammer for configuring the STEVAL-MKI109V3?

Did you check if the board is seen from the PC?


Hi, thanks for your answer. No, I was trying the DFU update as specified in

But your are right, the board is not seen from the PC (Ubuntu 18.04.5 LTS system). I run usb-devices in Terminal and it doesn't appears (I've checked the port works with my mouse).

Which is strange, since the board LED lights up.

Do you any recommendation? In the meantime I will try in a Windows PC.


HI @FCook.1​ ,

this might be only the power LED, that lights up when the power is plugged.

I use the tool on Windows, so I might be able to better help you whether something gets wrong with Windows.

I would suggest you to use the STM32CubeProgrammer software for Linux, after putting the board in DFU mode, as described in the user manual, and uninstall the DFuSe drivers, if you ever installed them.


Hi, I've now installed STM32CubeProgrammer software for Linux following all the instructions from manual.

Software opens OK, but when I click the refresh button to detect the STEVAL-MKI109V3, nothing happens, both pressing the buttons in the board to enter DFU mode or not.

Also I've installed Unico GUI in Win10, but the same, the STEVAL-MKI109V3 doesn't appears in COM port nor it is detected by Unico.

If you have any other recommendation, appreciated. So far I've followed all the ST manual available on the subject but it seems the STEVAL-MKI109V3 is not very user friendly as a plug in solution to test the MEMS sensors (at least not in Win10 and Ubuntu 18.04.5 LTS.).


Hi @FCook.1​ ,

did you follow the mechanical procedure:

  1. open the STM32cubeProgrammer, setting USB in the connection menu
  2. plug the USB cable on the STEVAL-MKI109V3
  3. press BT2, holding BT2 press BT3, release BT3 and then release BT2
  4. refresh the USB port, and a port name should appear

in order to put the device in DFU mode?


Hi Eleon, thanks again for your answer.

Yep, I tried that procedure (using different ports and cables just in case) and nothing happens.

Not sure if it has to do with Ubuntu, my notebook or what, but I think I will try to acces the data connecting the STEVAL-MKI208V1K to a breadboard and to a microcontroller.

Thanks anyway, regards,

Hi @FCook.1​ ,

But does this procedure work on Windows 10? You could try with a direct access to the VCOM, such as with Termite.

You can write the *ver command and check the different available active VCOM ports if the board doesn't respond.


I also noticed you have posted another question about the adapter, I saw Peter answered and I confirm he is correct. No need to take into account for pins different from the IIS3DWB datasheet ones.


Hi @FCook.1​ ,

do you have any updates about this?


Hi Eleon, I tried to make communication to STEVAL-MKI208V1K through Arduino (using similar code to

But there is no communication (I can't even get a read from register WHO_AM_I).

What are the chances the STEVAL-MKI208V1K I received was defective? That could explain the problems when using Unico as well.