Showing results for 
Search instead for 
Did you mean: Pro WTF? JUNK? Rah, Rah, Rah Misinformation and Gobble dee **bleep**!

Associate II

I'm a big fan of STMicro and have used several of their Dev and Eval boards with no issues.
A couple of weeks ago I got an email from ST about the new module. I looked at the videos and ordered one right away because I wanted to get it in time for the Webinar. The webinar was a disaster; way too much information with no time to take any notes. I figured I'd just watch it at my leisure later on but it was taken down in a couple of hours. So I started again with the Entry Mode video. The website said to download the ST BLE Sensor App which I did. The dice demo worked perfectly. At 1:10 into the video it said "Switch the box on and open the ST BLE Sensor Classic App on your phone" So I downloaded that and was able to follow the video then at 2:42 in the video it says to "Click on the Play button", I had to wait for a bit to scan for my board and then I clicked play. At 2:55 On the Overwrite board warning display I clicked OK. And then got "Error Board scanning has timed out. Exit the App and turn the board off."
Which I did; next time I tried it I got "There was an error loading the App on the board."
At this point the Pro appears to be junk. How do I proceed?



Accepted Solutions
Associate II

P.S. The link to Cube.MX is invalid on How to use in Pro mode, 07/29/21

View solution in original post

Federica Bossi
ST Employee

Hi @ericjwin ,

Welcome to ST Community!

So sorry for your disappointment. 
Which version of the app and of the board fw do you have? Are you using Android or IOS?

Let me know so that I can help you.

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Thank you, Federica, for your kind patience. My apologies for the tirade. I realized after a couple of days that the issue was probably user error :(  I tried to delete the post but couldn't.
I'm using Android Version 9 and Board Firmware Version: U585_STboxPRO_M12_0.8.1
I just noticed in the flyer that came with the board Step 4 is "Upload the latest available firmware to the PRO using the FOTA function." I'm unable to find that function in the App.
Please point me to a post about uploading the latest available firmware. And how to find the FOTA function. Thanks again.

Associate II

Thanks, Federica. I finally realized I'm way behind the curve on STM32 Development. I'll start with the STM32 MCU Developer Zone webpage. Please mark this topic Solved and Close.

Associate II

P.S. The link to Cube.MX is invalid on How to use in Pro mode, 07/29/21

I think I found what I was looking for: How to use the sensortile box in pro mode