Showing results for 
Search instead for 
Did you mean: 

Data Ready Interrupt H3LIS331DL

Associate II
Posted on February 04, 2014 at 08:30

How does one configure the data ready interrupt on the H3LIS331DL accelerometer? I've configured other accelerometers like LIS3DSH with success but I am stuck on this one.

I've tried both latched and pulsed interrupts, I've configured the signal on both INT1 and INT2 to the Data Ready on the configuration register but it doesn't seem to do anything. I would appreciate any guidance, I can post the code if needed.

Thanks in advance!!

Thiago REIS
Associate II
Posted on February 17, 2014 at 19:48


Would you please be able to share your registers setup?

Also, did the problem happen with only one item? Were you able to test with other H3LIS331DL IC?

Thank you!

Thiago Reis

Associate II
Posted on February 19, 2014 at 20:20

I solved the problem a while ago. Configurations were fine, Data Ready Interrupt ocurred but I didn't read the output registers, causing that no more Data Ready Interrupts would occur. When I took notice of this I easily solved the problem.

Goekhan Apak
Posted on December 12, 2016 at 18:01

Hi Wapers,

I know it is a little bit late but I have kind of the same problem. Could you post the setup of your code? I know you might not read it anymore but it is worth a try.