Showing results for 
Search instead for 
Did you mean: 

BlueCoin logging to SD Card with DataLog

Posted on April 10, 2018 at 14:21


I'm trying the example software for the BlueCoin, also DataLog. The USB streaming of data is working the way it's written in a Start guide. But I'm not moving forward with DataLog on SD Card. I'm going through the following steps:

1. Setting LoggingInterface = SDCARD_Datalog in main.c

2. loading program onto BlueCoin

3. Connecting BlueCoin to Cradle, which is connected to battery and has SD in it.

4. Tapping on a board, the way it's written in a guide.

Result: nothing happens. When I open the SD Card folder, there's nothing to see.

I also tried different SD card, didn't help.

Does anyone have the same issue and could help me?


#sdcard-logging #bluecoin #datalog
Davide G
ST Employee
Posted on May 03, 2018 at 14:56

Hi Natalia,

Could you please double check the following:

- you are using a micro-SDHC and not an old SD.

- you are doing a 'double tap' gesture to start the logging --> The LED should become brighter once active

If it still doesn't work you could try to use the binary provided within the package instead of recompiling it yourself.\STSW-STLKT01_V1.3.1\Projects\SensorTile\Applications\DataLog\Binary\DataLog_SDCard.bin

Posted on June 05, 2018 at 15:09

Hi David,

I am using micro-SDHC card as you are saying.

And I am able to upload the code as well on the bluecoin.

When I press the button 2 to start logging data in the SD card. The LED1 remains on all the time.

I was able to figure out that the problem which I was facing was that f_open function was giving me fr_disk_err. I didn't make any changes to the code that they have provided. Can you please help me with it? Thank you.

I am using Nucleo-L073RZ for debugging and uploading the code.

And then after uploading the code. I used the leds to find out the error while using sdcard (since we need to disconnect it from debugging hardware to attach sd card module.