Showing results for 
Search instead for 
Did you mean: 

VL53L0X sensor not working


The VL53L0X sensor chips (33 of them) i bought from Digikey isn't working in my PCBA. I tried to use sensor from the module which i purchased early on is working fine in my PCBA & shows distance readings. I suspect the batch had manufacturing defects as I bought it on January 15 2024.

Can someone help me with the solution ?


ST Employee

it's unlikely that you got a 'bad batch'. Because the FDA makes us adhere to the Class 1 laser safety specification, every single chip has to be individually inspected and calibrated. 

So what can go wrong. 

1) Xshutdown pin: if you don't pull that high, the chip will not turn on.

2) lack of power. These chips pull a fair bit of current when the run, so check for voltage drops.

3) I2C - it's almost always I2C. Check the SDA and SCL are high when the chip is not in use. Bus-stuck-low is the most common problem.

4) I2C byte-swap or word-swap. If your MCU does not match the endianness of the chip, you think you are sending reasonable commands, but you are not.

5) do you have a coverglass. If the glass is not good enough, you will get so much crosstalk your numbers will be wrong. Read the article:

It's important.

 6) check the light - with a camera, does the light turn on? (Don't use an Iphone - the phone's IR filter is too good.)

Sorry for the lack of specifics, but you didn't give me many hints.

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question. It helps the next guy.