Showing results for 
Search instead for 
Did you mean: 

VD6283_GUI application not starting on Windows




I'm trying to use the VD6283 sensor on a X-NUCLEO-6283A1 plugged in a Nucleo-64 STM32F401.


For this, I've installed the latest ST-Link drivers and the software STSW-IMG301. My board is well recognized on Windows device manager as a "STM STLink Virtual COM Port", but when I try to launch the VD6283_GUI application, I've the following error : "SensorSystem..ctor():Le format de la chaîne d'entrée est incorrect" / "SensorSystem..ctor():Input string is not in correct format".


I've tried to launch it also with admin privileges but it's still not working.


Application version : 1.0.0 - r862

Windows : 11 Pro



ST Employee


Sorry for this really late answer.

A new GUI has just been release for the VD6283 within the STSW-IMG301 package.

It is version : 1.0.1

Our community relies on fruitful exchanges and good quality content. You can thank and reward helpful and positive contributions by marking them as 'Accept as Solution'. When marking a solution, make sure it answers your original question or issue that you raised.

ST Employees that act as moderators have the right to accept the solution, judging by their expertise. This helps other community members identify useful discussions and refrain from raising the same question. If you notice any false behavior or abuse of the action, do not hesitate to 'Report Inappropriate Content'