cancel
Showing results for 
Search instead for 
Did you mean: 

STLINK-V3MINIE not recognized by Windows 10

RBerk.1
Associate II

HI, 

We have designed a test fixture for a 6 panel PCB in which we use 6 individual STM programmers (STLINK-V3MINIE) and we sometimes see a problem where windows no longer recognizes one of the programmers and we can't get it back (complete system reboot does not help).

We removed the faulty programmer and tried in on another windows 10 computer and there it is working fine. but when we place it back in the test fixture computer it is no longer recognized by the STMCube programmer software but windows does recognize it as a COM port device but not as a USB device.

We swapped out the programmer with a new one and it is working again (being recognized by STM Cube Programmer and everywhere in Windows).

 

Fast forward a month or 2 and we are seeing the same issue again and now we removed the faulty programmer and i didn't have another one laying around so i tried the old one.

This time it is being recognized by STM cube programmer and every where in Windows again.

 

Is there perhaps a known bug in STM cube Programmer when using multiple programmers in the system for a longer time or another explanation for this behavior?

 

Kind regard,

 

Richard

0 REPLIES 0