Showing results for 
Search instead for 
Did you mean: 

How to use the CubeMonitor in snapshot mode without trigger supported?

Associate II

I instrumented the code with the supplied code, and it works fine in STM Studio, but when used in CubeMonitor, after started, the dashbord just displays 'Acquisition started, waiting for value'. I've checked the data flow from STLink and found that only 'x' value present in the data payload, but without 'y' value.

Is there a way to trigger the data sample manually? Or supporting trigger is mandatory in snapshot mode?


Accepted Solutions

No update since a while, closing the post.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

View solution in original post


Dear SZENG.1,

Did you configure the node "variables" as expected ?

You have to :

-> select your monitored variables from the executable file

->select the snapshot mode (and verify that header address is detected )

-> select ( if you need it, it's not mandatory) a trigger variable and additional parameters of triggering ( value and start mode ).


Please come back to me if it's still not working.


Hi Landry,

Here is the situation:

The trigger function in the firmware code is not enabled, as it's not required and for saving RAM and ROM space;

The variables should have been configured correctly:

0693W000000UBWXQA4.pngIf the trigger is selected as 'off' like above, ​after clicked 'Start', the dashboard just shows 'waiting for value:


While, if trigger has been selected other than 'off' like below:


the acq in & out will show an error after started:


-Your node "variables" configuration is correct .

-In snapshot mode, the first point sent ( to set the first timestamp ) is an x only value, so this is also correct.( it means that the start is taking into account ).

-When you don't manage the trigger mode in your embedded application , the message "The trigger mode is not supported" is also correct.

So everything seems ok on CubeMonitor side.

Can you link the error output of your "acquisition in" node to debug node to see if you have some messages available ?

thank you

Dear Landry,



Sorry i was not clear,

remove the trigger in the variables node configuration. Then link the debug node to the second output of the node "acquisition in" (the one called "error").

Do you mean like this:


No any output, which means no error, right?

did you start an acquisition ?

ST Employee


The acquisition doesn’t start because you embedded application you are using (dataAcq files) was modified. The Size of buffer is defined with the formula: #define SNP_TRC_BUFFER_SIZE (50*(SNP_TRC_NB_MAX_WORD_VAR+1)) and unfortunatly Stm32cubemonitor doesn't allow modification on it. If the default buffer size is not enough large, I advice the increase the parameter SNP_TRC_NB_MAX_WORD_VAR (defined at 10 by default).

where do I go to set the variables?