Showing results for 
Search instead for 
Did you mean: 

Unbale to connect to the network

Associate III

We want to migrate from STM32L4+ to STM32U5 series of processor.. this latest software is not supported by older ide (1.6.0) so we need to migrate from stm32cubeide 1.6.0 to 1.10.0..

I have un-installed the older version and cleared all possible directories, disabled firewall, and removed antivirus. we are using windows7 OS.

Done appropriate proxy settings in Window-->Preferences-->Network Connections as per

Upon checking connection status in Window-->Preferences-->STM32Cube-->Firmware updater the check connection failure is noticed. I am unable to create any STM32 project as it needs a network connection for downloading the repository.

I am able to connect properly to another computer in our LAB. with the above-given procedures.

Kindly let me know pointers to debug this issue further.



Accepted Solutions
ST Employee

Hi @Agour.1​ ,

I'm suspecting a certificate issue with your proxy company.

The other PC Lab (where CubeIDE execution is OK), is also running on Windows 7 ?

Last trial to test:

  • Open the file "C:\ST\STM32CubeIDE_1.10.0\STM32CubeIDE\stm32cubeide.ini"
  • Remove the line
  • Delete your "C:\Users\<usename>\STM32CubeIDE" workspace
  • Delete .eclipse and .stm32cubemx folders
  • Retry to open CubeIDE, setup your usual manual proxy and perform a test connection (may be do the check twice)



View solution in original post

ST Employee

It's difficult to know where the connection problem could be, mostly because I don't really know how the credentials etc are supposed to be set up for your organization.

However, in order to create a new STM32 project with the latest firmware you could download it from, then in STM32CubeIDE you can go to Help -> Manage Embedded Software Packages -> From Local ... and import the package locally.

Thank You for your reply Markus.

the procedure for credentials entry is tested on 2 more machines and it worked on the first attempt.

My observation is that computers, where STM32cubeide was reinstalled are having this sort of connection problem. Wherever stm32cubeide is installed for the 1st time; no issue is there while connecting and downloading relevant packages.

Right now I created the project on some other computer and brought it back to my machine for continuing my work.

while trying Help -> Manage Embedded Software Packages -> From Local ... i faced the problem mentioned in the attached image. i downloaded the package from


some how I strongly feel the network connection must work for smooth creation of project. Please provide your support to make network connection work on my machine.. 

Where did you place the FW package?

I believe the Embedded Software Packages Manager is trying to search for the file in C:\Users\USER\STM32Cube\Repository

first i placed under C:\Users\Aditya\STM32Cube\Repository it did not allowed then I try to fetch from desktop then one version 1.1.0 was imported but 1.1.1 was not imported.

The 1.1.1 is not a stand-alone package, just a patch that's supposed to be applied to the 1.1.0 package. Does it come with some sort of ReadMe.txt to explain how to apply the patch?

ST Employee

Hi @Markus GIRDLAND​ , @Agour.1​ 

Can you please follow instruction detailed in the CubeMX UM1718:




ST Employee

And to be more correct, below the step by step procedure to install the patch:

  1. Download the STM32CubeU5 FW from:
  2. Put the zipped file under your FW repository
  3. Rename the zipped file from '' to ''
  4. Download now the patch from the same address
  5. Put the downloaded patch '' in a place other than your FW repository (e.g: your Download folder)
  6. Try now installing the patch '' using the 'From Local…' button

Let me know your feedback,


Thanks a ton Aymen.. it worked..

Can you plz suggest some remedy for my network connection issue..

Sorry for the trouble with the network settings in Eclipse, which sometimes can be a bit exhausting until you finally get it to work.

Is it possible that you work with your machine via VPN?

In this case, with STM32CubeIDE you are "already in your network", so to speak, and should not need any credentials or proxy settings. Instead of Preferences > General > Network Connections = Manual, please try the mode Direct, which ignores the settings for Host, Port etc. and uses your current Windows settings for network access.

After Apply and Close, please check again with Preferences > STM32Cube > Firmware Updater / Check Connection whether the connection is recognised.

Just a reminder - there are three modes in the network settings whose function is sometimes not obvious or misunderstood:

  • Direct: direct internet connection or already setup outside of Eclipse (proxy settings can be set, but are ignored)
  • Manual: internet connection via proxy settings (host, port, etc)
  • Native: internet connection via thge settings of the operating system, i.e. Windows, Linux or MacOSX (proxy settings can be set, but are ignored)

Does it work now?



In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.