cancel
Showing results for 
Search instead for 
Did you mean: 

No STLink Detected. CubeIDE 1.15 needs pc restart to program STM32

Sujoy_B
Associate

Hi, 

I am using an STM32F030C8T6 on a Bluepill PCB with STLink-V2 programmer. I have been successfully programming this board and others like it for a couple of years now. 

The issue is that on CubeIDE 1.15 on my laptop, the IDE refuses to program/ detect the ST-Link. ST-Link utility and cube programmer are able to detect the ST-Link easily as well as the STLinkUpgrade function within the CubeIDE can detect the ST-Link. 

It gets weirder as when I restart the PC, I can open the CubeIDE and program the STM32 once. If I try to enter the debug mode, the process gets interrupted midway but the Run command succeeds once. After that I get the message. "No ST-Link Detected. Please connect ST-Link and restart the debug session". The hardware works perfectly on two other PCs only my laptop is the issue. 

I have tried using other ST-Link devices on this laptop but there is no change. 
I've uninstalled and reinstalled CubeIde, CubeMX, ST-Link-server and ST-Link USB bridge but no use. 
I've tried updating libusb-1.0.dll but no luck there as well. 
I've tried uninstalling all STM32 windows driver packages and installing stsw-link009 - no change. 
I even tried installing st-link-servers Version 2-0-2, 2-1-0 and 2-1-1 again, no change. 


Snapshots of the successful and unsuccessful downloads are as below. Look forward to some guidance on this as I need the laptop for portable troubleshooting and diagnostics of my microcontroller.  

 

Sujoy_B_1-1714050521188.png

 

Sujoy_B_0-1714050502882.png

Regards, 

Sujoy

1 REPLY 1
Peter BENSCH
ST Employee

Please show us photos of your ST-LINK/V2, front and back. If possible, also a screenshot of the STM32CubeProgrammer when the ST-LINK is connected.

Regards
/Peter

In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.