Showing results for 
Search instead for 
Did you mean: 

[BUG] STM32CubeIDE Live Expression sometimes fail to evaluate expression.



I have noticed a little problem in the "Live Expressions" function.

The first time I open STM32CubeIDE and debug my firmware, I can see the value of all expressions previously written by me.

When I stop the debug and debug again, some expressions does'nt show the value. Instead this appears the message " Failed to evaluate expression".

The curious is that if I "rename" the expression the correct value appears again. For example, adding a space (or removing a space) at end of a expression with the message " Failed to evaluate expression" solve the problem.

This are happenning with anyone more?

This is a real bug?! How this problem can be solved?

Best regards, 

DIego Volpini



I had the same problem. I tried to read out an ADC but the variable with the values was either 0 or "Failed to evaluate Expression".

I found out I had a mistake in my Code, but it still doesn´t work as it should. Now my values changes randomly between 1380 and 1477, no matter what I do.

Best regards,



I experience the same issue. Watching abbout 10 expressions live, at least two of them show as a value "Failed to evaluate expression" on every relaunch. I can copy and paste as a new expression or add a space to the end of the failed expressions to get them back, but this is proving to be a real time sink. If anyone finds a workaround, I'd be grateful.

Peter.Farkas [hun]
Associate II


same problem here. I watching some variables by Live Expressions, and randomly appears "Failed to evaluate Expression". If I restart IDE, other variables said "Failed to evaluate Expression". If I add them again to the list, works fine. But it is very annoying to add them again and again.



I'm having the same issue where my Live Variables are showing values of 0 when I debug. @Community memberampbell​  I found a workaround by setting up a UART output to a terminal emulator (PuTTY). I output the values with HAL_UART_Transmit and a delay, and the numbers output consistently. This only works for debugging though if you can use UART and have a screen to output to.


I experience the same problem - whenever I restart the debug session some of the live expressions I entered during previous debug show up as "Failed to evaluate" while some other persist being okay. Only solution is to delete the failed and re-enter same ones as new - then they work. But until next relaunch.

This is really annoying :\

This is CubeIDE v1.3.1 on Windows 10 x64

Attaching screenshot, where after relaunch some expressions failed, but when I reentered first again at the bottom it works fine.


This has been around for like a year, and still not fixed.

Can we please get some attention from ST staff so this is finally fixed? Take a look please, @Markus GIRDLAND​ , would appreciate if you forward this accordingly

ad ho
Associate III

It is such an annoying bug. Can someone say something about it?

@Alexandre DA ROCHA​ @Alec BATH​ @Iain SCOTT​ @Francesco DI MARCO​ @Andrea Francesco MERELLO​ @Carole SORIA​ @Dan FRANZEN​ @Filip SCHWANK​ @Filippo Bonaccorso​ @Filippo SCRO'​ @Francesco Filippo CASATI​ @Gerald T FILIPPONE​ 

Thanks a lot!

Associate III

have this problem too ((

ad ho
Associate III

🙂 Still no luck reaching to ST for some attention :(

Associate III

today testing cubeide ver. 1.42.2 in Windows 10 == all ok, but this problem if working in Mac OC Catalina 10.15.7