Showing results for 
Search instead for 
Did you mean: 

How to use the RTL8723BU in "Ecosystem V2.0.0"?

Associate III

Hi All

​If you create a distribution with RTL8723BU enabled in the Linux kernel and boot, you will see the error message below.

[  30.102790] usb 2-1.2: 1f8: ff ff ff ff ff ff ff ff

[  30.106213] usb 2-1.2: RTL8723BU rev E (SMIC) 1T1R, TX queues 3, WiFi=1, BT=1, GPS=0, HI PA=0

[  30.118408] usb 2-1.2: RTL8723BU MAC: 34:c9:f0:8d:fc:72

[  30.124300] usb 2-1.2: rtl8xxxu: Loading firmware rtlwifi/rtl8723bu_nic.bin

[  30.131982] usb 2-1.2: Direct firmware load for rtlwifi/rtl8723bu_nic.bin failed with error -2

[  30.141236] usb 2-1.2: request_firmware(rtlwifi/rtl8723bu_nic.bin) failed

[  30.146569] usb 2-1.2: Fatal - failed to load firmware

[  30.155477] rtl8xxxu: probe of 2-1.2:1.2 failed with error -11

If you search for the "rtl8723_nic.bin" file on the entire Linux system, it doesn't exist.

Is there any other way to use RTL8723BU in "Ecosystem V2.0.0"?

The method shown on the ST WiKi site is not a solution as it assumes that the device driver is loaded normally.

Any suggestions on how to solve the above problem would be appreciated.

Thanks and regards


Associate III

Hi all.

I partially solved this problem.

It can be solved by taking the "rtl8723bu_nic.bin" file from the realtek git site and putting it in the "/lib/firmware/rtlwifi" folder.

However, when the Bluetooth and Wi-Fi functions are used together, one side of the Wi-Fi or Bluetooth is disconnected.

I'm looking for a solution to that problem. If you know anything that could be a hint, let me know.

Thanks and regards