Showing results for 
Search instead for 
Did you mean: 

Unlocking a STM32WB55CGU6

Associate II

I have an STM32WB55CGU6 processor. I initially started with updated the FUS from v0.5.3 to v1.0.1 via the STM32CubeProgrammer. 

This update was successful. 


I then proceeded with trying to load the v1.2.0 FUS. However I got the following error:


After doing some digging I came across this post,

This says I basically locked my processor. However none of this information is available on the Release Notes. 

Firstly why is this crucial information still not clearly visible on your Release Notes but rather hiding in this post regarding the locking of the processor.

Secondly how do I unlock the processor.


ST Employee

This is actually documented in the release notes related to the old revision of the cube package - 


Anyway, FUS 1.0.1 was available only in the cube package version 1.1. Today there is 1.19 which does not contain the old FUS version but rather 1.2.0 which can be applied directly over 0.5.3. The basic requirement is to always use the latest versions.

For your second question, you cannot unfortunately unlock this device.

Thank you, that note does not say anything about which specific MCU that rule applies to, for example the STM32WBXXG series accepts the v1.0.1 and will then accepts the most recent FUS on your Github page. I do not understand why the contains of the post in the forum cannot be copied in the release note to be more specific and also includes the processor variant type.

Please note you cannot apply the latest FUS without first applying the much older FUS first. I cannot understand why this is still not fixed in my case.

Is there any other hidden things that's exists in your forums but not in the release notes that we should be aware of, especially if it causes the MCU to lock for all the variants for the SM32WB series?

ST Employee

You are right, that release note does not state that, sorry for that. Anyway, it is stated in the official application note for FUS How to use STMicroelectronics firmware upgrade services for STM32WB MCUs - Application note and, on the Wiki, STM32WB Firmware Upgrade Service - stm32mcu.

And your second point - yes, with the latest FUS it is possible to update from 0.5.3 to 1.2.0 directly as specified in those sources. And the release note says to use stm32wb5x_FUS_fw_for_fus_0_5_3.bin in case you have the old FUS 0.5.3. This directly applies 1.2.0 - nothing bad happens if you then continued to the next step and tried to install stm32wb5x_FUS_fw.bin but it isn't necessary.