Showing results for 
Search instead for 
Did you mean: 

How to reset the P-Nucleo-WB55 to original and what are the possible problems with the sample code (BLE_HeartRate)?

Associate II

I am new to this area and I just bought two P-nucleo-wb55 boards. When I used the p2p server example, it can work properly and I am able to use my phone to control the on/off of the led. However, when I tried with another sample 'BLE_HeartRate', it can build properly but after I click debug, LED6 become red forever and I can no longer connect to the device anymore. I have also tried to look at it with st-link unity and stm32 targe information becomes always "Detection Failed" after the program 'BLE_HeartRate' is input.

I have tried with both boards and they have the exact same problem after clicking debug with 'BLE_HeartRate', so I guess it must be something wrong with this example.

But the main problem lays in how can I recover my boards to their original state or if the mcu are already damaged and unrecoverable. I had tried to connect the boot 0 to 3V but nothing seems to happen.

Any help would be appreciated. Thank you.

ST Employee

Hi @MX.1​ ,

I am not sure that STM32WB is supported by STLink Utility. Did you tried with STM32CubeProgrammer?


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

I have tried with STM32CubeProgrammer and it has the same situation, it is able to see the st-link configuration but unable to connect to the stm32wb chip showing "Error: No STM32 target found!"

Associate II