cancel
Showing results for 
Search instead for 
Did you mean: 

USB stopped connecting to STM32F405.

JWink.1
Associate II

I have an Adafruit STM32F405 Feather Express. I am compiling / uploading with Arduino IDE V2.1.0 with Windows 11 64. The board worked well for about a week, but no longer connects/shows up as Port 5 of USB. I was successfully connecting and uploading code with the Arduino IDE. After a few days away from the project, I discovered my STM32F405 Express no longer connects to the USB. I did attempt to install MS WDAC - see below.

When I jump B0 to +3.3 and press reset, (I hear a USB connect sound) under "Universal Serial Bus devices", "STM BOOTLOADER" appears in the device manager; it's always visible w/ or w/o the 405 if "View -> Show hidden devices" is checked). Unplugging the USB after a BO+reset generates a "disconnect" sound. Nothing appears under "Ports (COM & LPT)". When it was working, I could see it under "Port 5". Now, neither the STM32, nor any other device, is visible on the IDE under "Tools -> Port".

With the device manager and looking the STM BOOTLOADER Device Manager properties / Events tab / "Device install requested", I see "Device USB\VID_0483&PID_DF11\2065326F4D31 requires further installation." A B0+reset generates a "connect" sound, but no sound is generated otherwise.

The code I previously uploaded which simply sets up two PWM channels appears to be working - I can see waveforms on the 6 and 9.

If I connect a Nano to the USB, "USB-SERIAL CH340 (COM6)" appears and the Arduino IDE sees it as "COM6".

After seeing a caution icon on the "Windows Security - Actions recommended" icon in the task bar, I did attempt, apparently unsuccessfully, to install the Microsoft Windows Defender Application Control about the time the problem occurred. MS WDAC.

I did uninstall/reinstall Arduino IDE 2.1.0 The problem still exists. Same content in the Device Manager. Uninstalled/reinstalled "STM32 MCU based boards by STMMicroelectronics" 2.5.0 Per the instructions on Arduino IDE Setup setup page, "STM32 Cores by STMicroelectronics" no longer appears to exist, used a new version.

Any suggestions or hints would be appreciated.

Thanks -Jim

Edit: Adding the Event Viewer log

=============================================================

Installation configuration

Level: Information

time stamp: 5/27/2023 13:03:45

=============================================================

Device USB\VID_0483&PID_DF11\2065326F4D31 was configured.

Driver Name: oem180.inf

Class Guid: {88bae032-5a81-49f0-bc3d-a4ff138216d6}

Driver Date: 05/07/2018

Driver Version: 1.1.0.0

Driver Provider: STMicroelectronics

Driver Section: USB_Install

Driver Rank: 0xFF0001

Matching Device Id: USB\VID_0483&PID_DF11

Outranked Drivers:

Device Updated: false

Parent Device: USB\VID_045B&PID_0209\6&38487f98&0&1

=============================================================

Level: Error.

Time stamp: 5/27/2023 13:03:45

Device USB\VID_0483&PID_DF11\2065326F4D31 had a problem starting.

=============================================================

Driver Name: oem180.inf

Class Guid: {88bae032-5a81-49f0-bc3d-a4ff138216d6}

Service: WinUSB

Lower Filters:

Upper Filters:

Problem: 0x0

Problem Status: 0xC00000E5

3 REPLIES 3
JWink.1
Associate II

Got it working! I deleted C:\Users\...\AppData\Local\Arduino15\packages\stm32duino and C:\Users\...\AppData\Local\Arduino15\packages\STMicroelectronics then reloaded.

Could STM32 Cube Programmer not see/use the "STM32 BOOTLOADER" device?

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..
JWink.1
Associate II

Attempting to install Microsoft's Vulnerable Driver Blocklist was the only thing I think might have done it. It was working fine, I took a break for a few days. During that break, I installed. A few days later, I tried to connect and it no longer worked.