cancel
Showing results for 
Search instead for 
Did you mean: 

stm32l0 program sorftware

fang liang
Associate II
Posted on December 27, 2016 at 04:08

I  choose the device that is stm32l031f6 in my project,but i can'i find a suitable software to load my proogram,i try flash demo v1.1.1,v1.3 and v2.80 to do it ,but they are all failure,as seem as the mcuisp and flymcu ,which only program one times.so i want to know whether my opreration or software problems?

#stm32 #flashloader #stmflashloader
1 ACCEPTED SOLUTION

Accepted Solutions
Posted on December 29, 2016 at 10:05

Hi

‌,

I am pleased to inform you that you may keep using same initially selected device: STM32L031F6.

The attached release candidate of the STMFlashloader (V2.9.0) is supporting this product.

Could you please test it and let us know if you have any feedback?

The official release of

#

will be available on January 2

-Amel-

________________

Attachments :

STMFlashLoader Demo_V2.9.0RC4.zip : https://st--c.eu10.content.force.com/sfc/dist/version/download/?oid=00Db0000000YtG6&ids=0680X000006Hz03&d=%2Fa%2F0X0000000bFF%2FAAjDzYlY4c99uGjPMoomejDJXC9sVpG7kHD3xsQhF0o&asPdf=false

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

View solution in original post

5 REPLIES 5
Posted on December 27, 2016 at 21:43

Older software, ST should refresh

Tips, buy me a coffee, or three.. PayPal Venmo Up vote any posts that you find helpful, it shows what's working..
Posted on December 28, 2016 at 04:09

Thank you very mach,Clive one;Although,it is not a good message for me.I think i should choose anather MCU for my design;

Posted on December 29, 2016 at 10:05

Hi

‌,

I am pleased to inform you that you may keep using same initially selected device: STM32L031F6.

The attached release candidate of the STMFlashloader (V2.9.0) is supporting this product.

Could you please test it and let us know if you have any feedback?

The official release of

#

will be available on January 2

-Amel-

________________

Attachments :

STMFlashLoader Demo_V2.9.0RC4.zip : https://st--c.eu10.content.force.com/sfc/dist/version/download/?oid=00Db0000000YtG6&ids=0680X000006Hz03&d=%2Fa%2F0X0000000bFF%2FAAjDzYlY4c99uGjPMoomejDJXC9sVpG7kHD3xsQhF0o&asPdf=false

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Posted on December 29, 2016 at 10:34

Hi,Amel N;

Thank you very much .Do you known the specific time aboat STMFlashloader (V2.9.0) releasing?Because my project have no time,So i want to known specific time ,to decide change my project or not;

Posted on December 29, 2016 at 10:48

My recommendation is that you don't need to change the device if it is suitable for your application requirement.

The support of selected device on FlashLoader shouldn't be blocking for you [my understanding] as we already shared the suitable version with you.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.