Showing results for 
Search instead for 
Did you mean: 

Issues turning off trustzone on STM32 U585I-IOT02A development kit board


Hello, I am having an issue turning off trustzone on my device. While checking that the example project to blink the LEDs was properly working on my device (it wasn't, it kept getting secure faults.) I had gone into the STM32 Programmer to change some options to see if it would fix anything in regard to why I kept getting secure fault errors on my device. I accidentally locked WP1A and WP1B. Then I attempted to fix this by turning on and off the trusted level. Now I am stuck with WP1A and WP1B locked, trustzone enabled, and my RDP stuck at 55.

I've tried this article with no avail:

community st / s / article / how-to-disable-trustzone-on-stm32u5-series

And I've even tried accessing it with BOOT0 set to VDD.

Is my board bricked? Is there anything I can do to fix this? Any help is greatly appreciated.

Additionally, is there any guide to make sure that GPIO_IOToggle_TrustZone is properly working and setup other than the Readme?

ST Employee

Hi @CEarl.2​ 

I put myself in the same condition as you nto try to deactivate the trust zone by following the article step by step, I manage to deactivate the trustzone.

WP1A and WP1B locked have any incidence on Trustzone disabling.

After Disabling TrustZone, to unlock a WRP area, a regression to RDP level 0 must be launched.

Please refer to RM0456 chapter 7: Embedded flash memory (7.6.1 Write protection ) that will give you more details about this topic.



I am in this same situation on a STM32U575.  When I try and connect to the device in Hot Plug Mode as described, I get the following error: