Showing results for 
Search instead for 
Did you mean: 

Problem running the "Audio Playback and Record" firmware application with the STM32F746G Discovery board



when I load the application, everything compiles fine and its running. When I now connect my USB stick, it recognizes it, says on the touchscreen which vendor it is, how much GB it has, and so on. Now when I touch the screen to enter playback menu, it says "INFO: FatFs initialized!" and freezes. I debugged it and it freezes in the empty while loop of the HardFault_Handler in stm32f7xx_it.c. I am using a Spaceloop USB stick with 4 GB which implements FAT32, which should be fine according to Chans website I think. I also tried another one with FAT16, same result. For more information, I m using macOS Mojave and System Workbench as IDE. I also tried the BSP firmware example, which runs fine, I can listen to a file, use touch screen and so on. So I think I m just missing something when initializing my drive. I m thankful for any help, and if more information is needed to help me, I m willingly giving it 🙂

Tanks in advance!

Martin Urban