Showing results for 
Search instead for 
Did you mean: 

I'm using X-CUBE-USB-AUDIO package with different eval board, I am not able to record any voice. Is there any utility that needs to be use to make this package work? Please help me.

Associate II
ST Employee

Hello @JAgni.1​ ,

Check the configuration and the supported frequencies used.

I advise you to have a look at this UM2195 "User manual USB device audio streaming Expansion Package for STM32Cube", this will help on how to use the library for audio recording.

When your question is answered, please close this topic by choosing Select as Best.


When your question is answered, please close this topic by clicking "Accept as Solution".
Associate II

Hello @Imen DAHMEN​ ,

Thank you for your reply. Yes I have been following that User Manual. For recording there is not much written as compared to playback (With example). Also in the project for standalone configurations there is no .ios file which we can open in STM32 Cube IDE. So only one option left is MDK (Keil changes are hard). Is there any option to have only recording configuration in Keil?

I am not using same Board Support Package also (Using STM32F446RE MCU). Now my board is getting detected as USB Audio Device but using Audacity I am unable to record any data. So issue is not solved. So I searched where Mic Data is getting transferred, I have enabled every Macro still no success.

Please I am stuck for almost 3 weeks now. Would really appreciate anyone's help.