Showing results for 
Search instead for 
Did you mean: 

NN Issue: Invalid Firmware error for validate on target. Have tried many solutions from online.


E200(ValidationError): stm32: Unable to bind the STM AI runtime with "network" c-model: [] 

 connection to "serial:115200"/"115200" run-time fails 

 E801(HwIOError): Invalid firmware - COM4:115200

I have already tried the following:

  1. Using CubeMX and IAR IDE
  2. Uninstalling CubeMX
  3. Using older versions of STM IDE
  4. Using older versions of X-CUBE AI
  5. Confirmed that I am using M7
  6. Checked clocks
  7. Checked ports for any errors there
  8. Using other networks
  9. Directly hooking up to D0 and D1 for USART6
  10. Resets
  11. Many combinations of the above

In general I work with:

  • STM32F746G-Disco
  • STM32CubeIDE version 1.9.0
  • X-cube AI version 7.1.0
  • LeNet-5 for my network
  • Keras for my training and such

If anyone has any insights into the issue, that would be much appreciated. Attached is the .ioc file.