Showing results for 
Search instead for 
Did you mean: 

Nucleo F767ZI Unable to Configure Serial Port


I am trying to use the VCOM on my nucleo board to print data to my computer for debugging and I followed this tutorial on how to do it.

The first time I tried it, it worked, but almost every time since then putty has said it is unable to configure the serial port. I have tried other programs as well and all give me the same kind of error. The original program I was using was Terminus, which said the setcommstate parameter was incorrect. I have changed nothing in the code and one time I tried it again and it suddenly worked. Then on the next try without changing anything, just stopping and then starting again it went back to the same error, it seems like that was a fluke but I don't know what's going on. I'm on windows 10 and in the device manager the com port shows up, but when I hit debug in the STM32cubeide the com port for the serial connection disappears.

I know it's not much to go on, but if you have any ideas for how to fix this it would be a huge help. I'm very new to this stuff so sorry if its a basic question and I just couldn't find when it was asked previously.


USB devices are hard to run in debug mode, since it interrupts the flow of communication. Although as long as you don't set breakpoints, it should be working. Does it work in regular run mode?

If you feel a post has answered your question, please click "Accept as Solution".

The first time it did run in the regular run mode, but not since then. There are no breakpoints in the code either.