Showing results for 
Search instead for 
Did you mean: 

NUCLEO F429ZI board - Ethernet over usb - zperf example communication issue


I need help running the zerpf example with USB over ethernet for the STM32 NUCLEO F429ZI board. I could run the example with an ethernet port and ping the connection using iperf-2.0.5b-win32.

However, when I have configured the proj.conf file by adding these lines for setting Ethernet over USB.

CONFIG_NET_IPV6=n #Disabled this flag else mcu reboot again and again when the command is sent)

These configuration settings are also described here: After flashing the code, an RNDIS network is discovered via a USB connection, and I can manually set the network's IP. However, when I run iperf-2.0.5b-win32 in server mode on my Windows 11 and send zperf tcp upload 5001 10 1K 1M on the board, I get the error.

TCP upload failed (-116)

The connection is not established for TCP. Also, I am getting an error for UDP upload failed (-115). Can anyone help me understand what the problem might be?

ST Employee

Hello @msalik 

We are aware of your request on GitHub Ethernet over USB -zperf example for NUCLEO F429ZI board · zephyrproject-rtos/zephyr · Discussion #69056 ( 

In the meantime, have you checked this discussion Poor TCP performance · Issue #23302 · zephyrproject-rtos/zephyr (

I hope it will be helpful

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

My issue is different from the ones discussed in the links you’ve shared. In my case, communication isn’t being established at all. I encounter an error right from the start, which is why I posted my question. Thank you