Showing results for 
Search instead for 
Did you mean: 

ST-Link v2 not working with custom board

Associate II
Posted on January 21, 2016 at 15:04


i have my custom board all set up and checked and tried to program my STM32L051C6 with the ST-Link V2.

I am running the board with 1.8V, the NRST line has a 10k external pull up. SWDIO and SWCLK are just rooted to the header. Boot0 was tried with high and low. The header is the same as on the STM32L0 discovery kit, because at first I wanted to use this to program the device.(1.8V not possible with discovery board, my foult).

When I try so connect to device in STM32-Link Utility (lastest, also latest, firmware upgrade for ST-Link V2) I get the error: No target connected.

Settings: SWD;

 Connect under Reset;

Enabled Debug in low power mode;

Hardware Reset;

The connection from the debugging header to the debugger is done with jumper cable.

Connection: PIN 1 and 2 of debugger : 1.8V

PIN 3 and 4: Ground




The same connections where used with the discovery board(not using the on board debugger) with success.

I can measure 1.8V on PIN 2 if I remove it from header and debugger. So the debugger should definitely see 1.8V as MCU VDD.

I observe NRST, SWDIO and SWDCLK while trying to connect(here Boot0 = low):

Yellow NRST



scope_0 shows the timing between NRST and the clock start. It can already seen that SWDIO is on 1.8V until SWDCLK starts. Then it switches to 3.3V. Same as SWDCLK from the get got.

scope_1 shows the start of SWDCLK and SWDIO. Dutycylce is not 50%?

scope_2 shows the first activity on the SWDIO line.

scope_3 shows the second activity on the SWDIO line. They are alternating for 6 times than SWDIO and SWDCLK stop.

If there is more info I could provide please tell me. Right now i can not supply with 3.3V because an ADC with 2V max. supply is on the same supply.

kind regards,


Associate II
Posted on January 22, 2016 at 10:33

I build up another board, this time only the STM32 with supply. (100nF and 10uF connected between supply and ground near= 2-3mm the IC).

Supplied with 3.3V still not working.

EDIT: It is now working with 1.8V on my second board. For those that are interested. If the debugger detects supply voltage lower than 3.3V it will still use 3.3V SWDCLK and SWDIO, but when SWDIO is given to the STM32 it will accept the 1.8V data.

Associate II
Posted on January 22, 2016 at 12:47

To close this, in the end it was a soldering issue or an device issue. I changed the component on the first board and it works now.