Showing results for 
Search instead for 
Did you mean: 

Unico-GUI doesn't update X-axis for LIS2DUX12 (MKI109V3 + MKI238A)


Unico Version:

FW: V3.60.7

HW: MKI109V3 + MKI238A

OS: Win10


Can someone explain how the X/Y/Z axis on Unico are related to the OUT_X/Y/Z_H/L register readouts from the LIS2DUX12? On first glance, it looked like X-axis is not getting updated at all (I've tried with two MKI238A units, same results), but after looking closer at the register readout, it seemed like Y = OUT_X, Z = OUT_Y, and I have no idea where X came from or where OUT_Z went. 

Screenshot 2024-02-27 160019.jpg

What I see on the plots - no movement on X-axis, no matter how much I shook it.

Screenshot 2024-02-27 160338.jpg

Controls are set to "Easy Configuration"

Screenshot 2024-02-27 160257.jpg

Register settings and readouts.

Screenshot 2024-02-27 161814.jpg

Comparing OUT_X/Y/Z registers and what Unico displays. X_OUT was 0xFCB0 = -848, which was close to 'Y', and Y_OUT was 0xF190 = -3696, which was close to 'Z'. I couldn't tell where the "X=13" came from, and it never moved.


Federica Bossi
ST Employee

Hi @jtang ,

Welcome to ST Community!

Unfortunately we are aware of this problem and will solve it in the next MEMS Studio release in about two weeks, we are in the testing phase. I don't know when and if it will be fixed in Unico GUI as well, but I suggest you switch to MEMS Studio which is our new official tool. I will update you as soon as we release the new version with the fixed bug. Thank you for your patience and excuse us.

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.