Showing results for 
Search instead for 
Did you mean: 

STEVAL-MKI197V1: Pedometer Regression tool not working in offline mode



I am working with STEVAL-MKI197V1 to evaluate the steps detected by the pedometer.

By looking at the documentation, I found out that the pedometer can be better configured by using the UNICO GUI.

At the moment, I do not have the STEVAL-MKI109V3 motherboard, but I read that the Regression Tool can be used offline with custom data written in a specific format.

Therefore, I tried to use the regression tool with a simple txt file ('test_steps50.txt') containing the following data:

A_X [mg] 	 A_Y [mg] 	 A_Z [mg]
251	900	-119
259	907	-132
271	907	-145
276	904	-162
280	915	-166
263	908	-163
260	882	-171
225	869	-165
224	863	-181
228	860	-210
*Data are spaced with tabs

If I choose the folder containing this file and the output directory, after running the tool I do not get any configuration file (.ucf). The only file I get is the 'regression_tool.config' file in a different path with respect to the output directory defined in the UNICO GUI. However, this file is just telling me some data about the regression process.

I tried with different data logs (also those found in ST github repositories in which the files contain both the accelerations and gyroscope data) but nothing changed.

I am currently using a MacOS Monterey with chip Apple M1 Pro

Thanks in advance for your help