Showing results for 
Search instead for 
Did you mean: 

Did I just brick my evaluation board?

Posted on December 17, 2013 at 16:12


I bought a STEVAL-MKI109v1  evaluation board, and a STEVAL-MKI114v1 probe about 1,5 years ago.

Yesterday I tried to get it to work with the latest version of the Unico test software, but the program would always hang as soon as I clicked on anything that would read data from the sensor. So I figured I needed to upgrade the firmware.

In the Unico manual, it said that the Dfu firmware updater on the eval board needed upgrading first, before the firmware v3 properly said could be installed. So I uploaded the Dfu firmware that came with that latest version of Unico onto the evaluation board.

In order to update the firmware, the device needs to be put in Dfu mode, by holding a button while powering it up, so I did that.

However, the updater warned me that I could not back up the old firmware, nor verify whether the new firmware is correct, precisely because the device was in dfu mode. Now there's an obvious catch 22 because the updater will only run in dfu mode.

Nevertheless, the dfu firmware update went ok as far as I could tell.

Next I tried to uploaded the eMotion v2 firmware. I have a v1 device, but could not find any v1 firmware, so I assumed the v2 would cover both versions of the device.

Now the problem is that after having erased the old firmware at 92% the process stalled. I waited a bit, and then decided to reset and power cycle the device, knowing that would cause trouble, but I didn't see much of another way out of the situation.

So now the device is completely dead, even the power led will no longer light up.

Did I brick it, or is there a way to resuscitate it, and if so how and with which firmware?

Thank you for any advice.
Thiago REIS
Associate II
Posted on February 05, 2014 at 13:06

Hello Joeri,

I would like to request you to send me an email with the below information at

from there I will be able to supporty you on this and if there is need for ST to send a new evaluation board to you that will also be done.

- Project description

- Company

- Location

- Device(s) of interest

- Estimated volume

- Expected production date

Thank you,

Thiago REIS

Associate II
Posted on June 29, 2015 at 15:50

I have a similar issue, except I never got an error message or hanging. I was able to upgrade apparently successfully to ''DFU_Patcher_V1.0.2.dfu''. According to the manual, either the red or the green led should be on after this procedure, however, they were both on. The manual told me to reset using SW3, so I did, and now only the red led was on. After this, whenever I connect the USB, absolutely nothing happens. No lights, and the device is not detected by windows. Also, I can no longer enter DFU mode by holding in SW2, as nothing happens then either.

Please help.