Showing results for 
Search instead for 
Did you mean: 

Can't connect to device in MEMS Studio with Ubutnu 22.04.4 Linux

Associate II

I want to test X-Nucleo IKS02A1 board with MEMS Studio. I tried to connect to 4 different boards:

-Nucleo F767ZI,

-Nucleo F446RE,

-Nucleo L053R8 ,

-Nucleo WB15CC,

I always get the same error:

Some device is already connected


What can I  do. Is this some linux problem. Do I have to load some special firmware before connecting a board to MEMS studio. 



Federica Bossi
ST Employee

Hi @MAnto.2 ,

We did a check on our side and we are not able to reproduce the issue on a standard setup with Ubuntu 22.04.

It seems like some other process is using your serial port, that is why we would recommend you to :

1) run "fuser /dev/ttyACM0"  to check which process is using your serial port

2) run "fuser -k /dev/ttyACM0" to kill the process which is using your serial port

Note: you need to replace tty port with your respective ubuntu port.

We faced a similar issue on a device using ModemManager, which was connecting to our Nucleo board preventing us to use it. That is why we would suggest you to remove ModemManager if not needed using "sudo apt purge modemmanager"

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.