Showing results for 
Search instead for 
Did you mean: 

Adapter board STEVAL-MKI239A is not recognised by STEVAL-MKI109V3 motherboard

Associate III

Hi @Federica Bossi , I am trying to conduct data collection using STEVAL-MKI239A (for IMU LSM6DSV) and its motherboard STEVAL-MKI109V3. Following UM2116, I first installed the latest version of Unico (v9.16.0) for windows 10, and downloaded STM32CubeProgrammer for firmware upgrade. 

In STM32CubeProgrammer, even though I was trying to enter DFU mode, by "pressing button BT2 before supplying the board and release it when LED D6 lights up". But on my device monitor, the "serial device" only changed to "STM32 BOOTLOADER" rather than "STM device in DFU mode"... Anyway, the following steps 3-6 in Sec 2.2.2 of UM2116 works and by choosing ProfiMEMSToolV3.58.2_00_08000000.bin, the latest firmware seemed to be installed.

After disconnecting from STM32CubeProgrammer, I unplugged the motherboard and pushed the adapter into its socket. Then I plugged the USB in again, opened Unico, selected the adapter and clicked "select device". A window poped up saying the adapter has been not recognised, and the who_am_I value does not match... Even though the main GUI showed up, after clicking "connect", the LED D3 Yellow and LED D2 Red went on and the same window poped up.

I tried my best to push the adapter inside the socket, and measured the voltage between VDD/GND and VDDIO/GND. Both voltages are about 1.8V when I clicked "connect" and both yellow and red leds were on. The voltages were about 11.5mV when only LED D6 (blue) was on.

I changed into another USB cable, but the result was the same...

It seems that I have tried all possible troubleshooting ways. Is there anything else I should test/try before replacing the adapter? I am not sure if there is something wrong with my jumpers (shown in attached photo).

Many thanks in advance for your help!

Federica Bossi
ST Employee

Hi @ZSong ,

That's sound really strange. It seems that something went wrong in STM32CubeProgrammer.

Can you download Termite and then check the version fw of your STEVAL-MKI109V3 writing *ver?


You should see 9.16. Let me know!



In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Hi @Federica Bossi , thanks a lot for your reply.

After connecting to the correct serial port (COM6) and typing "*ver", it shows v3.58.2. I guess this matches the firmware I chose "ProfiMEMSToolV3.58.2_00_08000000.bin" (part of Unico installation files) when using STM32CubeProgrammer? I am a bit confused why this should be 9.16...

Thanks a lot again for your time and help.

Termite Version 3.58.2.png

Hi @Federica Bossi , following my previous post last week, I further tested the voltage in between VDD/VDDIO and GND and it is around 1.8V which seems fine.

However, I found something strange with Unico GUI. By selecting the device as "MKI239", the error window shows again saying that the adapter is not recognised. But when I select the device as "MKI236", no errors showed and I successfully entered the actual GUI, though no data output was shown either.

After that, if I went back and select "MKI239", there was still no errors (and no data output in "plot" after easy configuration). It worths mentioning that nothing seems happened after clicking "easy configuration".

Furthermore, literally after selecting "MKI236" and entering the GUI with no errors, I can select device as anyone in the list of Unico and am able to enter the GUI with no errors. I am not sure if this is a bug of Unico, or something is wrong with my MKI239 adapter.

And may I kindly ask what should I do to replace my adapter to a new one?

Thanks a lot in advance for your time!