cancel
Showing results for 
Search instead for 
Did you mean: 

X-NUCLEO-6180A1 GUI Crashing when trying to calibrate

RHill.4
Associate II

Hi, I am trying to use the X-NUCLEO-6180A1 GUI to perform a offset and x-talk compensation calibration. Something i get the offset one to complete, and others times I don't and then the x-talk one will not complete. It just seems to hang up in the middle of the calibration and I have to kill the GUI and restart, after many hard resets and restarting the GUI i cant seem to get a full calibration complete. Is this a known issue? is there anything I can do to be able to perform a full calibration? Attached is a screenshot of the hangup.

2 REPLIES 2
John E KVAM
ST Employee

We really did not do a very good job of the 6180 calibration.

Looks to me like you set it up for 50mm and it calibrated to 46. Hence a 4mm offset.

I'd set the override to 4mm and carry on with the crosstalk.

Not sure why it does not complete however.

It shoud.


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question. It helps the next guy.
RHill.4
Associate II

Ah I see, didn't know i could input that myself, thanks! I did have another questions also. When setting to 50mm, I used the end of the standoffs to the module as the "0mm" point, I think based on the Manual, there is a 8mm distance from the sensor to the edge of the standoffs, therefore i set the distance from the standoffs at 42mm to the target (White sheet) and then other 8mm to the sensor from the standoffs makes 50mm does this make sense/is correct way to calibrate? I attached a picture if that helps also to understand my question.