cancel
Showing results for 
Search instead for 
Did you mean: 

Vl53L7 ranging result distance not correct with status 6

hoainguyen265
Associate II

Hi guys, I'm using vl53l7cx without cover glass.

I use the Example_1_ranging_basic in VL53LMZ_ULD_API driver, but i alway receive the result with target_status 6 and the  result's distance_mm seem not correct.

Eg i put an target about 300mm in front of the sensor and get result as below in resolution 4x4:

1168-6, 1348-6, 1302-6, 1243-6

1213-6, 1371-6, 1330-6, 1249-6

1240-6, 1381-6, 1332-6, 1253-6

1215-6, 1360-6, 1317-6, 1248-6

So i wonder if i miss any config to get the correct ranging result?

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Status 6 is RANGECOMPLETE_NO_WRAP_CHECK

  • These are always generated on first frame after the sensor starts.
  • Then occasionally they can be generated if a target is marginal and appears/disappears in consecutive frames.

 

So first question is : the data you are showing are from the first frame received or not ?.

 

Then .. suspicious that the ranges you record are about 4x the expected value….which just so happens to be the ratio that the raw data is adjusted by depending on this define in the platform.h file…

/*

* @brief The macro below can be used to avoid data conversion into the driver.

* By default there is a conversion between firmware and user data. Using this macro

* allows to use the firmware format instead of user format. The firmware format allows

* an increased precision.

*/

 

//#define    VL53LMZ_USE_RAW_FORMAT

 

Is this parameter defined ? If yes, you would see target ranges 4x larger than they expect.

 


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

View solution in original post

4 REPLIES 4
Anne BIGOT
ST Employee

Hello,
Can you please give more details about your use-case ?
Which hardware are you using ? Is it a ST EVK or your own PCB board ?
You are mentioning the VL53L7CX and the VL53LMZ_ULD_API driver used for VL53L7CH.

Regards

Anne


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Hi @Anne BIGOT , thanks for your reply. We use the VL53L7CH in custom board.

Regards

Hoai Nguyen

Hi @Anne BIGOT this is the device info when i get from the chip:

- device id: 240
- revision id: 2
- module id: 1

Status 6 is RANGECOMPLETE_NO_WRAP_CHECK

  • These are always generated on first frame after the sensor starts.
  • Then occasionally they can be generated if a target is marginal and appears/disappears in consecutive frames.

 

So first question is : the data you are showing are from the first frame received or not ?.

 

Then .. suspicious that the ranges you record are about 4x the expected value….which just so happens to be the ratio that the raw data is adjusted by depending on this define in the platform.h file…

/*

* @brief The macro below can be used to avoid data conversion into the driver.

* By default there is a conversion between firmware and user data. Using this macro

* allows to use the firmware format instead of user format. The firmware format allows

* an increased precision.

*/

 

//#define    VL53LMZ_USE_RAW_FORMAT

 

Is this parameter defined ? If yes, you would see target ranges 4x larger than they expect.

 


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.