STM32CubeMX (MPUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

I used STM32CubeMX version 6.3.0 thinking it was the correct version for Ecosystem 3.0 just to discover I should have used STM32CubeMX version 6.2.1. Is there a way to move my projects backwards?

I have several projects already configured for STM32MP157C and I don't want to have to build them all over again if I can help it. Also, my team is asking I not move the Ecosystem (but if that is my only answer I will.)

SLetter by Associate III
  • 454 Views
  • 2 replies
  • 1 kudos

Resolved! undefined reference to `HAL_ADC_Init'

I've been trying for hours to read an analog value from a pin and write it over UART with no success on my STM32MP1. I've assigned PF14 to ADC2_INN2 and set IN2 to "IN2 Differential", then I generate the code and when I try to build I get a bunch of ...

msche.1 by Associate III
  • 990 Views
  • 5 replies
  • 0 kudos

STM32MP157C-DK2 - Can not enable UART8 in uboot?

Hi,We are trying to replace UART8 instead of UART4 in uboot and UART8 doesn't work for us.We change to UART3 it work just fine.When we open STM32CubeMX, hopefully we can find something, but seem the application doesn't allow us to select UART8.Anyone...

0693W00000aIwmdQAC.png
Dat Tran by Senior II
  • 294 Views
  • 0 replies
  • 0 kudos

Resolved! IPCC interrupt issue in stm32mp157A ?

Hello,We are using STM32MP157A.We are working on IPCC from A7-0,A7-1 to M4.We are getting IPCC interrupt A7-1 to M4,But when we are not getting interrupt from A7-0 to M4.In cubeMx it is showing NVIC to IPCC RX1 and TX1, but not showing to RX0,TX0.we ...

0693W00000Y8qf8QAB.png 0693W00000Y8qfSQAR.png
Srikanth1 by Associate III
  • 353 Views
  • 1 replies
  • 0 kudos

Resolved! Where a stm32mp1xx.h file?

I ran GENERATE-CODE on STM32CubeMX and M4 files were created. There is #include "stm32mp1xx.h" in stm32mp1xx_hal_def.h in Include, but there is no stm32mp1xx.h file. where is it?

安保.1 by Associate II
  • 274 Views
  • 1 replies
  • 0 kudos