Showing results for 
Search instead for 
Did you mean: 

STM32F769I-DISCO, MB1225 B-02, A201800875

Associate II


I have another problem with the board "STM32F769I-DISCO, MB1225 B-02, A201800875".

I wanted to restore the original firmware of the board.

Download from ST site the image "10_2020\32F769IDISCOVERY_demo\Binary\STM32769I-DISCO_DEMO_V1.0.0_FULL.hex". Loaded it according to the "32F769IDISCOVERY_demo\readme.txt" file. I used two applications for loading:

1)STM32 ST-LINK Utility 4.6

2)STM32CubeProgrammer 2.4.0

with the same result, load the main picture with ST logo and stops. Nothing else. I think the reason is the wrong firmware revision. Before deleting the original " FW" I checked System Info and their FirmWare revision is 1.2, but I didn't find anywhere on ST site firmware such revision.

But when I do the same on the previous board 

" Board: STM32F769I-DISCO, MB1225 B-02, A192400285

 Screen : MB1166 A-02, A192400688"

with the 

"10_2020\32F769IDISCOVERY_demo\Binary\STM32769I-DISCO_DEMO_V1.0.0_FULL.hex". Loaded it according to the "32F769IDISCOVERY_demo\readme.txt" file. with STM32CubeProgrammer 2.4.0 all is working as expected.

So many problems with the board with the latest revision, with which we worked a lot normally in the past.

And the main problem is that the touchscreen does not work in our program (the separate case was opened).

Please help us to resolve it.

Best regards,




Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..


I do have the exact same problem. I want to be able to restore the firmware of my STM32F769I-DISCO in version V1.2.0 as stated in the original board´s firmware system Information page but could not find the firmware image.

Unfortunatedly your link above does not work anymore.

Can you please point me to a new source?

Thank you!

Hello @JakeW ,

The binary demonstration files for STM32F769I-DISCO are available under Tools & Software/Compiled demos section.



Sorry, but this is not the solution I was seeking.

I am searching for the exact firmware version 1.2.0 that was on my board before I started evaluating.

The package you pointed me to contains other binaries of V1.0.0 and V1.4.0.

Although those might possibly work I would like to restore the original bianry I received when I bought this board.

Regards, Jake.


Also seems to be gerrymandering the forum metrics, because the poster isn't the OP, and it doesn't answer the question.

Perhaps someone can go fix the forum transition issue where ST lost the attachment of the file that was requested. I'll go look in my archives..


Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..