Showing results for 
Search instead for 
Did you mean: 

Hi, I'm attempting to read memory data of my STM32F030c8t6_board (I got boards on, picture in details section). I can not connect to my device. See details section for explanations. Best regards, Sylvain


Used tools:

  • stm32cubeprogrammer
  • STLink-v2 (wired pins: 7:swdio, 9: swclk, 1: vcc, 8: gnd), the dev board usb is plugged to supply the chip.
  • tried with all reset combinations, bus clock configs and boot0 config.
  • tried with openocd as well (see console log below)
  • tried with one of my own board (stm32f4x) to check if my tools are still working properly, I can read memory of the chip perfectly.


  • Do I miss something to make chip debug probe connection working ? I generally never had trouble to connect it to my boards. Anyway this is the first time I work on STM32f0 series.
  • I heard possible fake MCU's sold on some websites (I used banggood, the price were quite low), do you thing it could be the case ?

Log of stm32cubeprogrammer:

16:12:13 : ST-LINK SN : 55FF6F064986565728531287

16:12:13 : ST-LINK FW : V2J37S7

16:12:13 : Board      : --

16:12:13 : Voltage    : 3.28V

16:12:13 : Error: ST-LINK error (DEV_TARGET_CMD_ERR)

16:12:18 : ST-LINK SN : 55FF6F064986565728531287

16:12:18 : ST-LINK FW : V2J37S7

16:12:18 : Board      : --

16:12:18 : Voltage    : 3.28V

16:12:18 : Error: ST-LINK error (DEV_TARGET_CMD_ERR)

16:12:23 : ST-LINK SN : 55FF6F064986565728531287

16:12:23 : ST-LINK FW : V2J37S7

16:12:23 : Board      : --

16:12:23 : Voltage    : 3.28V

16:12:23 : Error: ST-LINK error (DEV_TARGET_CMD_ERR)

16:12:35 : ST-LINK SN : 55FF6F064986565728531287

16:12:35 : ST-LINK FW : V2J37S7

16:12:35 : Board      : --

16:12:35 : Voltage    : 3.28V

16:12:35 : Error: No STM32 target found!

Log from openocd:

openocd -f /usr/share/openocd/scripts/interface/stlink-v2.cfg -f /usr/share/openocd/scripts/target/stm32f0x.cfg -c 'init'

Open On-Chip Debugger 0.10.0

Licensed under GNU GPL v2

For bug reports, read

Info : auto-selecting first available session transport "hla_swd". To override use 'transport select <transport>'.

Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD

adapter speed: 1000 kHz

adapter_nsrst_delay: 100

none separate

Info : Unable to match requested speed 1000 kHz, using 950 kHz

Info : Unable to match requested speed 1000 kHz, using 950 kHz

Info : clock speed 950 kHz

Info : STLINK v2 JTAG v37 API v2 SWIM v7 VID 0x0483 PID 0x3748

Info : using stlink api v2

Info : Target voltage: 3.282795

Error: init mode failed (unable to connect to the target)

in procedure 'init'

in procedure 'ocd_bouncer'



Almost certainly the boards bought from banggood are counterfeit. May or may not be the issue here. I would double check solder connections and BOOT0 pin status.

If you feel a post has answered your question, please click "Accept as Solution".


Thanks for the feedback.

Unfortunately, I tested 2 units and none of them worked (same behavior, even after trials to change boot0 pin status). Therefore, the soldering issue probability seems to be poor. I just have an other question: do you have another (more trustable) supplier of such parts ? I could try to order and test a few of these and finally notice if the parts behave similarly than those found on banggood.

Perhaps you can take a picture of the board/chip you actually have, the picture above seems like stock photography. Large, Clear and In Focus.

Does yours have the B2 or RESET pin? Connect Under Reset modes would need connection to the NRST pin of the ST-LINK/V2

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
That particular board isnt made by any reputable suppliers afiak. You can get official nucleo boards from digikey for fairly cheap.
If you feel a post has answered your question, please click "Accept as Solution".

What if they are just not flashed with any code so SWD peripheral is not set?

Where they blinking when you first plugged them to power out of the box?

by the way if its bluepill the normal chip you would expect is the stm32f103c8

we dont need to firmware by ourselves, lets talk