Showing results for 
Search instead for 
Did you mean: 

Weird lag while building the workspace and after the building is done.

Senior III

Something weird is going on when I'm trying to build my project on STM32CubeIDE 1.10.1 on Windows.

The process takes several minutes (instead of less than a minute).

I launched Task Manager and Resource Monitor to investigate it, and what I found out is even more weird.

I select the "Clean" option to rebuild everything. As I expected, I get all CPU cores used for compiling the code and this is perfectly fine. However, it finishes as expected in less than a minute then the STM32CubeIDE just freezes doing nothing.

0693W00000UoShhQAF.pngThe app is totally unresponsive.

Here's what I have on Task Manager:

0693W00000UoShrQAF.pngThe cores still seem to be doing something, but it's just 5% usage by the IDE process.

The app died, however, the huge lag is there even when it doesn't die. I usually see the message on the console it's done compiling, but then the mysterious super long process starts. It's nothing on the progress bar or the console, the app is just unresponsive.

Another symptom that might be a part of the same problem: I see on the console I have 1 warning. I click on "Problems" tab and I have to wait like 1 minute before it appears. Of course, during the time the IDE doesn't react to anything.

I use 10 threads for the compiler instead of total available 16, just not to make it (or the system) unresponsive. It doesn't help. 1 thread, 10 threads, 16 threads - it always hangs for a couple of minutes after compiling the project. The GUI is unresponsive the whole time. Windows works normally, other apps work as nothing was happening. I have plenty of free RAM, the disk and network activity are normal.

IDK when exactly it started. It worked normally, sometimes it even works normally. But recently I have this weird lag more and more often.

Typical console output when it hangs:



AV software?

Network, Mirroring or remote storage?

Github for Desktop?

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

No AV except built in Windows Defender.

No remote storage.

I have Github for Desktop installed, but it's not currently run. BTW, I have object files excluded with .gitignore.

ST Employee

Hello @Adam �?yskawa​ 

First let me think you for posting.

First could you please provide the workspace log for analysis.

Second, try to export the project you are working with as an archive.


Then import it in another workspace using the "Project from Folder or Archive" option.

0693W00000UoWDlQAN.png 0693W00000UoWEFQA3.png 

Then tell me If the issue still exists.

Kind regards,


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Thank you for checking that out, however - I currently have problem with replicating the issue, after restarting the PC the IDE seems to be working normally.

I'm not sure if the problem won't reoccur. When it happens, I'll provide the log for analysis.