Showing results for 
Search instead for 
Did you mean: 

stm32mp157c moving from Developer Package to Distribution Package


I'm having a challenge moving changes from our Developer Package to our Distribution package. We've modified device trees using CubeMX for our board and have all the changes for TF-A, optee, u-boot and the kernel working in the Developer Package. Now when I take those changes and port them into the distribution package and build with bitbake it is giving me the following error.

Hit any key to stop autoboot: 1 NOTICE: CPU: STM32MP157CAC Rev.Z NOTICE: Model: STMicroelectronics custom STM32CubeMX board - openstlinux-6.1-yocto-mickledore-mp1-v23.06.21 INFO: PMIC version = 0x21 INFO: Reset reason (0x15): INFO: Power-on Reset (rst_por) 
INFO: FCONF: Reading TB_FW firmware configuration file from: 0x2ffe2000
INFO: FCONF: Reading firmware configuration information for: stm32mp_io
INFO: Instance 1
INFO: Boot used partition fsbl1
NOTICE: BL2: v2.8-stm32mp1-r1.0(debug):devtool-patched-dirty(27df046a)
NOTICE: BL2: Built : 15:15:46, Apr 30 2024
INFO: BL2: Doing platform setup
INFO: RAM: DDR3-DDR3L 16bits 533000kHz
INFO: Memory size = 0x20000000 (512 MB)
INFO: BL2: Loading image id 1
INFO: Loading image id=1 at address 0x2ffff000
INFO: Image id=1 loaded: 0x2ffff000 - 0x2ffff1ea
INFO: FCONF: Reading FW_CONFIG firmware configuration file from: 0x2ffff000
INFO: FCONF: Reading firmware configuration information for: dyn_cfg
INFO: FCONF: Reading firmware configuration information for: stm32mp1_firewall
INFO: BL2: Loading image id 4
INFO: Loading image id=4 at address 0xde000000
INFO: Image id=4 loaded: 0xde000000 - 0xde00001c
INFO: OPTEE ep=0xde000000
INFO: OPTEE header info:
INFO: magic=0x4554504f
INFO: version=0x2
INFO: arch=0x0
INFO: flags=0x0
INFO: nb_images=0x1
INFO: BL2: Loading image id 8
INFO: Loading image id=8 at address 0xde000000
INFO: Image id=8 loaded: 0xde000000 - 0xde038bb8
INFO: BL2: Skip loading image id 9
INFO: BL2: Loading image id 2
INFO: Loading image id=2 at address 0xc0500000
INFO: Image id=2 loaded: 0xc0500000 - 0xc0520f40
INFO: BL2: Skip loading image id 16
INFO: BL2: Loading image id 5
INFO: Loading image id=5 at address 0xc0100000
INFO: Image id=5 loaded: 0xc0100000 - 0xc01f1964
NOTICE: BL2: Booting BL32
INFO: Entry point address = 0xde000000
INFO: SPSR = 0x1d3
I/TC: Early console on UART#4
I/TC: Embedded DTB found
I/TC: OP-TEE version: devtool-patched-dev (gcc version 12.2.0 (GCC)) #1 Tue Apr 30 15:15:46 UTC 2024 arm
I/TC: WARNING: This OP-TEE configuration might be insecure!
I/TC: WARNING: Please check
I/TC: Primary CPU initializing
E/TC:0 0 set_voltage_then_clock:134 Failed to set clock
E/TC:0 0 Panic

At first I thought it was an issue with op-tee, but once I added some debug statements and it seems like it is related to MPU clock source.

image (4).png

So I shifted gears and have been looking into TF-A. When I replaced my Distribution Package TF-A with the one from the Developer Package, it worked!

So there is some difference between the Developer Package TF-A and Distribution Package TF-A. But the only change I made was to copy the device tree changes from Developer Package to the Distribution Package. Any help would be appreciated.

Christophe Guibout
ST Employee

Hello @badi95,


First of all, I would recommand to use devtool to have an idea about the real content of tf-a built through Distribution Package, and compare it with the version you successfully built through Developper Package: devtool modify command will apply patches from all tf-a-stm32mp recipies to to show what will be really compiled.


The second point is that error comes from OP-TEE : did you apply your OP-TEE patches from Developper Package to Distribution Package ?





In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.