Showing results for 
Search instead for 
Did you mean: 

LCD display not turning on - STM32MP135F-DK



I just received my STM32MP135F-DK in the mail today. I was able to use STM32CubeProgrammer v2.16.0 to populate the device using the Starter Package, which I downloaded from here:

The file I downloaded was named:


And the file that I used in the STM32CubeProgrammer to download the firmware to the device was named:


After downloading the firmware to the device and toggling the switches to the correct mode, I powered up the device and the display never turned on. However, I was able to open a terminal on the device through the serial connection.

Everything seems to be working fine as far as the terminal is concerned. I even managed to connect the device to my home network and SSH into it.

The LCD display shows no signs of life. I've never seen the splash screen, or even a flicker out of it. There is no backlight turning on.

I tried flashing it with the Starter Package version 4.1.0 instead of 5.0.0, but I'm getting the same result.

I'd appreciate some help getting this device working. Does this sound like a hardware issue? Or perhaps the screen is defective on this device?

ST Employee

Hi @ChrisCrossCrash ,


This looks indeed abnormal, seems your board is defective. 

I recommand you to contact your distributor to get a new board



In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.