Showing results for 
Search instead for 
Did you mean: 

Custom board openstlinux distribution problem

Associate II

Hi there,

 I am building custom board with openstlinux distribution package with following config

Build Configuration:

BB_VERSION          = "2.0.0"

BUILD_SYS           = "x86_64-linux"

NATIVELSBSTRING     = "universal"

TARGET_SYS          = "arm-ostl-linux-gnueabi"

MACHINE             = "stm32mp1-silico"

DISTRO              = "openstlinux-weston"

DISTRO_VERSION      = "4.0.4-snapshot-20230428"

TUNE_FEATURES       = "arm vfp cortexa7 neon vfpv4 thumb callconvention-hard"

TARGET_FPU          = "hard"

DISTRO_CODENAME     = "kirkstone"

ACCEPT_EULA_stm32mp1-silico = "1"

GCCVERSION          = "11.%"

PREFERRED_PROVIDER_virtual/kernel = "linux-stm32mp"

It all goes splendidly and board boots up with following log.

   2.663121] EXT4-fs (mmcblk1p10): recovery complete

[   2.724133] EXT4-fs (mmcblk1p10): mounted filesystem with ordered data mode. Opts: (null). Quota mode: disabled.

[   2.733150] VFS: Mounted root (ext4 filesystem) on device 179:10.

[   2.740392] devtmpfs: mounted

[   2.745412] Freeing unused kernel image (initmem) memory: 1024K

[   2.750736] Run /sbin/init as init process

[   2.759550] Run /etc/init as init process

[   2.763368] Run /bin/init as init process

[   2.768285] Run /bin/sh as init process

/bin/sh: can't access tty; job control turned off

/ #

I've expected it use systemd as init process but it seems to be using /bin/sh. Thing is there is no

sbin/init (nor /etc/init for that matter) in rootfs. The system is configured to use systemd as init

bitbake-getvar VIRTUAL-RUNTIME_init_manager shows

# $VIRTUAL-RUNTIME_init_manager [2 operations]

#  set /home/redacted/Projects/openstlinuxdist-silico/layers/meta-st/meta-st-openstlinux/conf/distro/include/

#    "systemd"

#  set /home/redacted/Projects/openstlinuxdist-silico/layers/openembedded-core/meta/conf/distro/include/

#    [_defaultval] "sysvinit"

# pre-expansion value:

#  "systemd"


Setting it in local.conf didn't help either. systemd is also appears in


 Is there anything I might be missing?

 Thanks in advance