cancel
Showing results for 
Search instead for 
Did you mean: 

Different PCROP data between ST-Link and ST-Bootloader

S-.1
Associate II

Hello,

with a new never programmed stm32g031 chip I get different values for PCROP if the same chip is read with ST-LINK or with bootloader+UART.

The CubeProgrammer version is 2.7.0

Which is the reason for that?

Thank you

5 REPLIES 5
Uwe Bonnes
Principal II

Do you use recent versions of both programs? Do both programs support the stm32g031?

S-.1
Associate II

The program used is the same, CubeProgrammer version 2.7.0, and run in the same Linux PC.

The most recent version available is 2.8.1

I can give it a try.

The chip is detected and others operation like programming o reading flash are ok.

S-.1
Associate II

Upgraded to 2.8.1 but the problem is still there

Houda GHABRI
ST Employee

Hi @S-.1​ ,

I confirm, the PCROP values displayed in ST-Link and the bootloader are different, but it's just the display that differs (one shows the start address of the sector and the other the end address ) .I want to highlight that both are handled correctly by CubeProgrammer.

I will submit a ticket internally to harmonize the display in future version of STM32CubeProgrammer.

Hope this helps you, if your question is answered, please close this topic by choosing Select as Best. This will help other users find that answer faster.

Houda

Flast.21
Associate

Hi @Houda Ghabri

Using the ST bootloader only region 1A is shown. Reading data using st-link the regions shown are two: 1A and 1B