cancel
Showing results for 
Search instead for 
Did you mean: 

SPI2 MOSI line has weak output

Brother Theo
Associate II

I have a weird one. Using an STM32H723 Nucleo board. The MOSI line for SPI2 is giving me trouble. The edges are slow (see picture). All I am doing for this test is transmitting on SPI2 with nothing attached but the scope. I am using STM32CubeIDE and the MX config tool. What could be causing this?

1 ACCEPTED SOLUTION

Accepted Solutions

So on lqfp144 its not PC3, but PC3_C .

-> 

AScha3_0-1716928510913.png

AScha3_1-1716928554626.png

 

AScha3_2-1716928714320.png

So you are on an analog mux connected pin, about 400 ohms internal resistance.

You cannot change this ... for hi speed, use another pin. NOT an crazy analog connected.

(I didnt make this design - so dont blame me. I got similar experience , so i know . )

If you feel a post has answered your question, please click "Accept as Solution".

View solution in original post

9 REPLIES 9
nickliangbin
Associate II

Hi Theo,

Can you provide more details on your project settings? Which mood is the SPI2 in, polling, IT or DMA? What is the SPI SCK?

Nick

Muhammed Güler
Senior III

Have you tried changing the maximum output speed setting of the pins you use for SPI?

AScha.3
Chief

Signal looks like : too much capacitive load or speed to low (setting!).

So set probe at 10:1 and port speed medium (or hi, depends on your SPI clk speed).

Always set speed to lowest possible (to avoid excessive ringing), but high enough for the desired speed.

see ds for possible/useful speed settings.

medium:

AScha3_0-1716800141914.png

 

If you feel a post has answered your question, please click "Accept as Solution".

SPI2 is in polling mode, clock is 1.07MBits/sec

I set the speeds to very high, no change to the sigs. There is no loading except for the scope probe which is 10:1. When I run the same test on an F743 Nucleo the sigs look great. 

The pin in question is PC3 and it is not used on the nucleo board. 

So on lqfp144 its not PC3, but PC3_C .

-> 

AScha3_0-1716928510913.png

AScha3_1-1716928554626.png

 

AScha3_2-1716928714320.png

So you are on an analog mux connected pin, about 400 ohms internal resistance.

You cannot change this ... for hi speed, use another pin. NOT an crazy analog connected.

(I didnt make this design - so dont blame me. I got similar experience , so i know . )

If you feel a post has answered your question, please click "Accept as Solution".
Brother Theo
Associate II

Thanks! This was the issue. I moved the line to an alternate pin and it works fine. Thankfully the new pin is unused on my board/